neredeyse tüm kitaplıkları kurarken pip sorunu

| | | | | | | | | | | | | | | | | | | | | | | | | | |

Neredeyse her şeyi yüklemek için pip kullanmakta zorlanıyorum. Kodlamada yeniyim, bu yüzden belki de bunun yanlış yaptığım bir şey olduğunu düşündüm ve genellikle işe yarayan ihtiyaç duyduğum şeylerin çoğunu elde etmek için easy_install'ı seçtim. Ancak şimdi nltk kitaplığını indirmeye çalışıyorum ve ikisi de işi bitirmiyor.

girmeyi denedim

sudo pip install nltk 

ama şu yanıtı aldı:

/Library/Frameworks/Python.framework/Versions/2.7/bin/pip 4 Mayıs Cumartesi 00:15:38 2013 İndiriliyor /unpacking nltk Alma sayfası https://pypi.python.org/simple/nltk/ URL getirilemedi [bağlantıyı göndermek için daha fazla itibar gerekiyor]: SSL sertifikasını onaylarken bir sorun oluştu: <urlopen hatası [Errno 1] _ssl .c:504: error:0D0890A1:asn1 kodlama rutinleri:ASN1_verify:unknown ileti özeti algoritması> nltk için indirme bağlantıları ararken URL'yi atlayacak [bağlantıyı göndermek için daha fazla itibar gerekir]/simple/nltk/ Alma sayfası [daha fazla itibar gerekir gönderi bağlantısı]/simple/ URL getirilemedi https://pypi.python.org/simple/: SSL sertifikasını onaylarken bir sorun oluştu: <urlopen error [Errno 1] _ssl.c:504: error:0D0890A1: asn1 kodlama rutinleri:ASN1_verify:bilinmeyen mesaj özeti al goritm> nltk için indirme bağlantıları ararken URL'yi atlayacak [bağlantıyı göndermek için daha fazla itibara ihtiyaç var] Dizin temel URL'si alınamıyor [bağlantıyı göndermek için daha fazla itibara ihtiyaç var] nltk sürümlerini aramak için URL'ler: * [bağlantıyı göndermek için daha fazla itibara ihtiyaç var] Alma sayfası [bağlantıyı göndermek için daha fazla itibar gerekiyor] URL getirilemedi [bağlantıyı göndermek için daha fazla itibar gerekiyor]: SSL sertifikasını onaylarken bir sorun oluştu: <urlopen hatası [Errno 1] _ssl.c:504: error:0D0890A1:asn1 kodlaması rutinler:ASN1_verify:bilinmeyen mesaj özeti algoritması> nltk için indirme bağlantıları ararken URL'yi atlayacak [bağlantıyı göndermek için daha fazla itibar gerekiyor] nltk gereksinimini karşılayan herhangi bir indirme bulunamadı nltk için hiçbir dağıtım bulunamadı İstisna bilgisi: Geri izleme (en son çağrı): Dosya "/Library /Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/basecommand.py", satır 139, ana durumda = self.run (seçenekler, bağımsız değişkenler) Dosya "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/commands/install.py" , satır 266, çalışma gereksinimi_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle) Dosya "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip -1.3.1-py2.7.egg/pip/req.py", satır 1026, prepar_files içinde url = finder.find_requirement(req_to_install, upgrade=self.upgrade) Dosya "/Library/Frameworks/Python.framework/Versions/ 2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/index.py", lin e 171, find_requirement yükseltmesinde DistributionNotFound("%s için hiçbir dağıtım bulunamadı" % req) DistributionNotFound: nltk --easy_install kitaplığın yüklü parçaları için hiç dağıtım bulunamadı ve kod, çalıştırmayı denedikten sonra çok hızlı bir şekilde sorunla karşılaştı o. 

Bu konu hakkında herhangi bir fikriniz var mı? Pip'i nasıl çalıştırabileceğime veya bu arada sorunu çözebilecek bir şeye ilişkin geri bildirimlerinizden gerçekten memnun olurum.