problema de pip instalando quase qualquer biblioteca

| | | | | | | | | | | | | | | | | | | | | | | | | | |

Tenho dificuldade em usar o pip para instalar quase tudo. Eu sou novo na codificação, então pensei que talvez isso fosse algo que eu estivesse fazendo errado e optei pelo easy_install para obter a maior parte do que eu precisava fazer, o que geralmente funcionou. No entanto, agora estou tentando baixar a biblioteca nltk, e nenhum dos dois está fazendo o trabalho.

Tentei digitar

sudo pip install nltk 

mas obtive a seguinte resposta:

/Library/Frameworks/Python.framework/Versions/2.7/bin/pip executado em sábado, 4 de maio 00:15:38 2013 Baixando /unpacking nltk Obtendo página https://pypi.python.org/simple/nltk/ Não foi possível buscar URL [precisa de mais reputação para postar o link]: Ocorreu um problema ao confirmar o certificado SSL: <urlopen error [Errno 1] _ssl .c:504: erro:0D0890A1:asn1 codificando rotinas:ASN1_verify:desconhecido algoritmo de resumo de mensagem> Irá pular URL [precisa de mais reputação para postar link]/simple/nltk/ ao procurar links de download para nltk Obtendo página [precisa de mais reputação para post link]/simple/ Não foi possível buscar URL https://pypi.python.org/simple/: Ocorreu um problema ao confirmar o certificado SSL: <urlopen error [Errno 1] _ssl.c:504: error:0D0890A1: rotinas de codificação asn1:ASN1_verify:unknown message digest al goritmo> Irá pular URL [precisa de mais reputação para postar link] ao procurar links de download para nltk Não é possível buscar URL base de índice [precisa de mais reputação para postar link] URLs para procurar versões para nltk: * [precisa de mais reputação para postar link] Obtendo página [precisa de mais reputação para postar o link] Não foi possível buscar o URL [precisa de mais reputação para postar o link]: Ocorreu um problema ao confirmar o certificado SSL: <urlopen error [Errno 1] _ssl.c:504: error:0D0890A1:asn1 encoding rotinas:ASN1_verify:algoritmo de resumo de mensagem desconhecido> Irá pular URL [precisa de mais reputação para postar link] ao procurar links de download para nltk Não foi possível encontrar nenhum download que satisfaça o requisito nltk Nenhuma distribuição encontrada para nltk Informações de exceção: Traceback (última chamada mais recente): Arquivo "/Biblioteca /Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/basecommand.py", linha 139, no status principal = self.run (opções, argumentos) Arquivo "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/commands/install.py" , linha 266, em execute require_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle) File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip -1.3.1-py2.7.egg/pip/req.py", linha 1026, em prepare_files url = finder.find_requirement(req_to_install, upgrade=self.upgrade) File "/Library/Frameworks/Python.framework/Versions/ 2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/index.py", lin e 171, em find_requirement raise DistributionNotFound("Nenhuma distribuição encontrada para %s" % req) DistributionNotFound: Nenhuma distribuição encontrada para nltk --easy_install instalou fragmentos da biblioteca e o código teve problemas muito rapidamente ao tentar executar isto. 

Alguma opinião sobre este assunto? Eu realmente aprecio algum feedback sobre como posso fazer o pip funcionar ou algo para contornar o problema enquanto isso.