pip problem z instalacją prawie każdej biblioteki

| | | | | | | | | | | | | | | | | | | | | | | | | | |

Mam trudności z użyciem pip do zainstalowania prawie wszystkiego. Jestem nowy w kodowaniu, więc pomyślałem, że może to jest coś, co robiłem źle i zrezygnowałem z easy_install, aby uzyskać większość tego, czego potrzebowałem, co generalnie działało. Jednak teraz próbuję pobrać bibliotekę nltk i nie kończę zadania.

Próbowałem wpisać

sudo pip install nltk 

ale otrzymałem następującą odpowiedź:

/Library/Frameworks/Python.framework/Versions/2.7/bin/pip uruchomiono w sobotę 4 maja, 00:15:38 2013 Pobieranie /unpacking nltk Pobieranie strony https://pypi.python.org/simple/nltk/ Nie można pobrać adresu URL [potrzebuję więcej reputacji, aby opublikować link]: Wystąpił problem z potwierdzeniem certyfikatu ssl: <urlopen error [Errno 1] _ssl .c:504: error:0D0890A1:asn1 procedury kodowania:ASN1_verify:nieznany algorytm skrótu wiadomości> Pominie adres URL [potrzeba większej reputacji, aby opublikować link]/simple/nltk/ podczas szukania linków do pobrania dla nltk Pobieranie strony [potrzeba większej reputacji do post link]/simple/ Nie można pobrać adresu URL https://pypi.python.org/simple/: Wystąpił problem z potwierdzeniem certyfikatu ssl: <urlopen error [Errno 1] _ssl.c:504: error:0D0890A1: Procedury kodowania asn1:ASN1_verify:nieznany skrót wiadomości al gorytm> Pominie URL [potrzebujesz więcej reputacji, aby opublikować link] podczas szukania linków do pobrania dla nltk Nie można pobrać podstawowego adresu URL indeksu [potrzebujesz więcej reputacji, aby opublikować link] Adresy URL do wyszukiwania wersji dla nltk: * [potrzebujesz więcej reputacji, aby opublikować link] Pobieranie strony [potrzebujesz więcej reputacji, aby opublikować link] Nie można pobrać adresu URL [potrzebujesz więcej reputacji, aby opublikować link]: Wystąpił problem z potwierdzeniem certyfikatu ssl: <urlopen error [Errno 1] _ssl.c:504: error:0D0890A1:asn1 kodowanie procedury:ASN1_verify:nieznany algorytm skrótu wiadomości> Pominie URL [potrzeba więcej reputacji, aby opublikować link] podczas szukania linków do pobrania dla nltk Nie można znaleźć żadnych pobrań spełniających wymagania nltk Nie znaleziono żadnych dystrybucji dla nltk Informacje o wyjątku: Traceback (ostatnie wywołanie ostatnie): Plik "/Biblioteka /Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/basecommand.py", wiersz 139, w statusie głównym = self.run (opcje, argumenty) Plik "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/commands/install.py" , wiersz 266, w uruchomieniu Requirements_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle) File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip -1.3.1-py2.7.egg/pip/req.py”, wiersz 1026, w ready_files url = finder.find_requirement(req_to_install, upgrade=self.upgrade) Plik "/Library/Frameworks/Python.framework/Versions/ 2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/index.py", lin e 171, w find_requirement podnieś DistributionNotFound("Nie znaleziono żadnych dystrybucji dla %s" % req) DistributionNotFound: Nie znaleziono żadnych dystrybucji dla nltk --easy_install zainstalował fragmenty biblioteki i kod bardzo szybko wpadł w kłopoty przy próbie uruchomienia to. 

Czy masz jakieś przemyślenia na ten temat? Naprawdę byłbym wdzięczny za informację zwrotną na temat tego, jak mogę uruchomić pips lub coś, co w międzyczasie obejmie problem.