pip-probleem bij het installeren van bijna elke bibliotheek

| | | | | | | | | | | | | | | | | | | | | | | | | | |

Ik vind het moeilijk om pip te gebruiken om bijna alles te installeren. Ik ben nieuw op het gebied van coderen, dus ik dacht dat dit misschien iets was dat ik verkeerd heb gedaan en heb gekozen voor easy_install om het meeste van wat ik nodig had gedaan te krijgen, wat over het algemeen werkte. Nu probeer ik echter de nltk-bibliotheek te downloaden, en geen van beide krijgt de klus geklaard.

Ik heb geprobeerd in te voeren

sudo pip install nltk 

maar kreeg het volgende antwoord:

/Library/Frameworks/Python.framework/Versions/2.7/bin/pip uitgevoerd op za 4 mei 00:15:38 2013 Downloaden /unpacking nltk Pagina ophalen https://pypi.python.org/simple/nltk/ Kan URL niet ophalen [meer reputatie nodig om link te plaatsen]: Er was een probleem met het bevestigen van het ssl-certificaat: <urlopen-fout [Errno 1] _ssl .c:504: error:0D0890A1:asn1 coderingsroutines:ASN1_verify:unknown message digest algorithm> Zal URL overslaan [meer reputatie nodig om link te plaatsen]/simple/nltk/ bij het zoeken naar downloadlinks voor nltk Pagina ophalen [meer reputatie nodig om post link]/simple/ Kon de URL niet ophalen https://pypi.python.org/simple/: Er is een probleem opgetreden bij het bevestigen van het ssl-certificaat: <urlopen-fout [Errno 1] _ssl.c:504: error:0D0890A1: asn1-coderingsroutines:ASN1_verify:unknown message digest al goritme> Zal URL overslaan [meer reputatie nodig om link te plaatsen] bij het zoeken naar downloadlinks voor nltk Kan index basis-URL niet ophalen [meer reputatie nodig om link te plaatsen] URL's om te zoeken naar versies voor nltk: * [meer reputatie nodig om link te plaatsen] Pagina ophalen [meer reputatie nodig om link te plaatsen] Kon URL niet ophalen [meer reputatie nodig om link te plaatsen]: Er is een probleem opgetreden bij het bevestigen van het ssl-certificaat: <urlopen-fout [Errno 1] _ssl.c:504: error:0D0890A1:asn1-codering routines:ASN1_verify:unknown message digest algoritme> Zal URL overslaan [meer reputatie nodig om link te plaatsen] bij het zoeken naar downloadlinks voor nltk Kon geen downloads vinden die voldoen aan de vereiste nltk Helemaal geen distributies gevonden voor nltk Uitzonderingsinformatie: Traceback (meest recente oproep als laatste): Bestand "/Bibliotheek /Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/basecommand.py", regel 139, in hoofdstatus = self.run (opties, argumenten) Bestand "/Bibliotheek/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/commands/install.py" , regel 266, in run requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle) Bestand "/Bibliotheek/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip -1.3.1-py2.7.egg/pip/req.py", regel 1026, in prepare_files url = finder.find_requirement(req_to_install, upgrade=self.upgrade) Bestand "/Bibliotheek/Frameworks/Python.framework/Versions/ 2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/index.py", lin e 171, in find_requirement raise DistributionNotFound("Geen distributies gevonden voor %s" % req) DistributionNotFound: Geen distributies gevonden voor nltk --easy_install installeerde fragmenten van de bibliotheek en de code kwam heel snel in de problemen bij het proberen te draaien het. 

Heeft u een idee over dit probleem? Ik zou het erg op prijs stellen wat feedback over hoe ik pip aan het werk kan krijgen of iets om het probleem in de tussentijd op te lossen.