거의 모든 라이브러리를 설치하는 pip 문제

| | | | | | | | | | | | | | | | | | | | | | | | | | |

pip를 사용하여 거의 모든 것을 설치하는 데 어려움을 겪고 있습니다. 저는 코딩에 익숙하지 않기 때문에 이것이 제가 잘못하고 있는 것일 수도 있다고 생각하고 필요한 작업을 대부분 수행하기 위해 easy_install을 선택 해제했으며 일반적으로 효과가 있었습니다. 그러나 이제 nltk 라이브러리를 다운로드하려고 하는데 둘 다 작업이 완료되지 않습니다.

입력을 시도했습니다.

sudo pip install nltk 

하지만 다음 응답을 받았습니다.

/Library/Frameworks/Python.framework/Versions/2.7/bin/pip run on Sat May 4 00:15:38 2013 Downloading /unpacking nltk 페이지 가져오기 https://pypi.python.org/simple/nltk/ URL을 가져올 수 없음 [링크를 게시하려면 평판이 더 필요함]: SSL 인증서를 확인하는 데 문제가 있었습니다: <urlopen 오류 [Errno 1] _ssl .c:504: 오류:0D0890A1:asn1 인코딩 루틴:ASN1_verify:알 수 없는 메시지 다이제스트 알고리즘> nltk에 대한 다운로드 링크를 찾을 때 URL [링크를 게시하려면 더 많은 평판 필요]/simple/nltk/ 건너뛰기 페이지 가져오기 [더 많은 평판 필요 포스트 링크]/simple/ URL을 가져올 수 없습니다 https://pypi.python.org/simple/: SSL 인증서를 확인하는 데 문제가 있었습니다: <urlopen error [Errno 1] _ssl.c:504: error:0D0890A1: asn1 인코딩 루틴:ASN1_verify:알 수 없는 메시지 다이제스트 al 알고리즘> nltk에 대한 다운로드 링크를 찾을 때 URL [링크를 게시하려면 평판이 더 필요]를 건너뛸 것입니다. 인덱스 기본 URL을 가져올 수 없습니다. [링크를 게시하려면 평판이 더 필요] nltk에 대한 버전을 검색하기 위한 URL: * [링크를 게시하려면 평판이 더 필요함] 페이지 가져오기 [링크를 게시하려면 평판이 더 필요함] URL을 가져올 수 없음 [링크를 게시하려면 평판이 더 필요함]: SSL 인증서를 확인하는 데 문제가 있었습니다: <urlopen 오류 [Errno 1] _ssl.c:504: error:0D0890A1:asn1 인코딩 루틴:ASN1_verify:알 수 없는 메시지 요약 알고리즘> nltk에 대한 다운로드 링크를 찾을 때 URL [링크를 게시하려면 더 많은 평판 필요] 건너뛰기 nltk 요구 사항을 충족하는 다운로드를 찾을 수 없음 nltk에 대한 배포를 전혀 찾을 수 없음 예외 정보: 추적(가장 최근 호출 마지막): 파일 "/Library /Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/basecommand.py", 139행, 기본 상태 = self.run (옵션, 인수) 파일 "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/commands/install.py" , 266행, 실행 require_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle) 파일 "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/site-packages/pip -1.3.1-py2.7.egg/pip/req.py", 1026행, prepare_files url = finder.find_requirement(req_to_install, upgrade=self.upgrade) 파일 "/Library/Frameworks/Python.framework/Versions/ 2.7/lib/python2.7/site-packages/pip-1.3.1-py2.7.egg/pip/index.py", 린 e 171, in find_requirement raise DistributionNotFound("%s에 대한 배포가 전혀 없습니다." % req) DistributionNotFound: nltk --easy_install 설치된 라이브러리 조각에 대한 배포가 전혀 없으며 실행을 시도할 때 코드에 매우 빠르게 문제가 발생했습니다. 그것. 

이 문제에 대한 의견이 있으십니까? pip를 작동하게 하거나 그 동안 문제를 해결할 수 있는 방법에 대한 피드백에 감사드립니다.