pip install numpyの問題-RuntimeError:壊れたツールチェーン:単純なCプログラムをリンクできません

| | |

numpy(およびscipyとmatplotlib)をvirturalenvにインストールしようとしています。

これらのエラーが発生し続けます:

  RuntimeError:壊れたツールチェーン:できません簡単なCプログラムをリンクする----------------------------------------クリーンアップ...コマンドpythonsetup.pyegg_infoがエラーコード1で失敗しました

xcode用のコマンドラインツールがインストールされています

  $ which gcc / usr / bin / gcc $ which cc / usr / bin / cc  

MacOSX10.9ではbrewがインストールされたpythonを使用しています

編集
はい、pipでインストールしようとしています。
トレースバック全体が巨大です(> 400行)

その一部を次に示します:

  Cコンパイラ:cc- fno-strict-aliasing -fno-common -dynamic -arch x86_64 -arch i386 -g -Os -pipe -fno-common -fno-strict-aliasing -fwrapv -mno-fused-madd -DENABLE_DTRACE -DMACOSX -DNDEBUG -Wall- Wstrict-prototypes -Wshorten-64-to-32 -DNDEBUG -g -fwrapv -Os -Wall -Wstrict-prototypes -DENABLE_DTRACE -arch x86_64 -arch i386 -pipe compiファイルオプション: "-Inumpy / core / src / private -Inumpy / core / src -Inumpy / core -Inumpy / core / src / npymath -Inumpy / core / src / multiarray -Inumpy / core / src / umath -Inumpy / core / src / npysort -Inumpy / core / include -I / System / Library / Frameworks / Python.framework / Versions / 2.7 / include / python2.7 -c "cc:_configtest.c clang:エラー:不明な引数:"-mno -fused-madd "[-Wunused-command-line-argument-hard-error-in-future] clang:注:これは将来のハードエラーになります(警告にダウングレードできません)clang:エラー:不明な引数:"-mno-fused-madd" [-Wunused-command-line-argument-hard-error-in-future] clang:注:これは、将来の障害でハードエラーになります(警告にダウングレードできません)。削除:_configtest.c _configtest.oトレースバック(最後の最後の呼び出し):ファイル "< string>"、行17、< module>ファイル"/Users/bdhammel/Documents/research_programming/julia_env/build/numpy/setup.py"、行192、< module> setup_package()ファイル "/Users/bdhammel/Documents/research_programming/julia_env/build/numpy/setup.py"、185行目、setup_package configuration = configuration)ファイル "/Users/bdhammel/Documents/research_programming/julia_env/build/numpy /numpy/distutils/core.py "、169行目、セットアップでreturn old_setup(** new_attr)ファイル" /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/core.py "、152行目、セットアップdist.run_commands()ファイル" /System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py "、953行目、run_commands self.run_command (cmd)ファイル "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py"、行972、run_command cmd_obj.run()ファイル "/ Users / bdhammel / Documents / research_programming / julia_env / build / numpy / numpy / distutils / command / egg_info.py "、10行目、実行self.run_command(" build_src ")ファイル"/System/Library/Frameworks/Python.framework/Versions/2.7 /lib/python2.7/distutils/cmd.py "、326行目、run_com mand self.distribution.run_command(command)ファイル "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/distutils/dist.py"、行972、run_command cmd_obj.run()ファイル"/Users/bdhammel/Documents/research_programming/julia_env/build/numpy/numpy/distutils/command/build_src.py"、153行目、実行self.build_sources()ファイル "/Users/bdhammel/Documents/research_programming/julia_env/ build / numpy / numpy / distutils / command / build_src.py "、164行目、build_sources self.build_library_sources(* libname_info)ファイル" / Users / bdhammel / Documents / research_programming / julia_env / build / numpy / numpy / distutils / command / build_src.py "、299行目、build_library_sources sources = self.generate_sources(sources、(lib_name、build_info))ファイル" /Users/bdhammel/Documents/research_programming/julia_env/build/numpy/numpy/distutils/command/build_src.py "、386行目、generate_sources source = func(extension、build_dir)ファイル" numpy / core / setup.py "、674行目、get_mathlib_infoでraise RuntimeError(" Broken toolch ain:単純なCプログラムをリンクできません ")RuntimeError:壊れたツールチェーン:単純なCプログラムをリンクできません