ImportError : aucun module nommé pip

| | | | | | | | | | | | | | | | | | | |

OS : Mac OS X 10.7.5 Python Ver : 2.7.5

J'ai installé setuptools 1.0 avec ez_setup.py depuis https://pypi.python.org/pypi/setuptools Ensuite, je télécharge pip.1.4.1 pkg depuis https://pypi.python.org/pypi/pip/1.4.1.

Exécuter (sudo) python setup.py install dans iTerm montre que

exécution de l'installation exécution de bdist_egg exécution de egg_info écriture des exigences sur pip.egg-info/requires .txt écrivant pip.egg-info/PKG-INFO écrivant des noms de niveau supérieur à pip.egg-info/top_level.txt écrivant dependency_links à pip.egg-info/dependency_links.txt écrivant des points d'entrée à pip.egg-info/entry_points Avertissement .txt : manifest_maker : fichier standard "setup.py" introuvable lecture du fichier manifeste "pip.egg-info/SOURCES.txt" écriture du fichier manifeste "pip.egg-info/SOURCES.txt" installation du code de la bibliothèque sur build/bdist .macosx-10.6-in tel/egg exécutant install_lib avertissement : install_lib : "build/lib" n'existe pas -- aucun module Python à installer création build/bdist.macosx-10.6-intel/egg création build/bdist.macosx-10.6-intel/egg/EGG -INFO copie pip.egg-info/PKG-INFO -> build/bdist.macosx-10.6-intel/egg/EGG-INFO copie pip.egg-info/SOURCES.txt -> build/bdist.macosx-10.6-intel/egg/EGG-INFO copie pip.egg-info/dependency_links.txt -> build/bdist.macosx-10.6-intel/egg/EGG-INFO copie pip.egg-info/entry_points.txt -> build/bdist.macosx-10.6-intel/egg/EGG-INFO copie pip.egg-info/not-zip-safe -> build/bdist.macosx-10.6-intel/egg/EGG-INFO copie pip.egg-info/requires.txt -> build/bdist.macosx-10.6-intel/egg/EGG-INFO copie pip.egg-info/top_level.txt -> build/bdist.macosx-10.6-intel/egg/EGG-INFO créant "dist/pip-1.4.1-py2.7.egg" et en ajoutant "build/bdist.macosx-10.6-intel/egg" en supprimant " build/bdist.macosx-10.6-intel/egg" (et tout ce qu'il contient) Traitement de pip-1.4.1-py2.7.egg en supprimant "/Users/dl/Library/Python/2.7/lib/python/site-packages /pip-1.4.1-py2.7.egg" (et tout ce qu'il contient) en créant /Users/dl/Library/Python/2.7/lib/python/site-packages/pip-1.4.1-py2.7.egg Extraction de pip-1.4.1-py2.7.egg vers /Users/dl/Library/Python/2.7/lib/python/site-packages pip 1.4.1 est déjà la version active dans easy-install.pth Installation du script pip pour /Users/dl/Library/Python/2.7/bin Installation du script pip-2.7 sur /Users/dl/Library/Python/2.7/bin installé /Users/dl/Library/Python/2.7/lib/python/site-packages/ pip-1.4.1-py2.7.egg Traitement des dépendances pour pip==1.4.1 Fini le traitement des dépendances pour pip==1.4.1 

Puis j'ai saisi pip install, le message d'erreur s'affiche comme ça

Traceback (dernier appel le plus récent) : Fichier "/Library/Frameworks/Python.framework/Versions/2.7/bin/pip", ligne 9, dans <module> load_entry_point("pip==1.4.1", "console_scripts", "pip")() Fichier "build/bdist.macosx-10.6-intel/egg/pkg_resources.py", ligne 357, dans load_entry_point Fichier "build/bdist .macosx-10.6-intel/egg/pkg_resources.py", ligne 2394, dans load_entry_point Fichier "build/bdist.macosx-10.6-intel/egg/pkg_resources.py", ligne 2108, dans load ImportError : Aucun module nommé pip 

Quelqu'un a déjà rencontré le même problème et peut me donner des conseils pour le résoudre ?