How do you fix “runtimeError: package fails to pass a sanity check” for numpy and pandas?

StackOverflow

This is the error I am getting and, as far as I can tell, there is nothing useful on the error link to fix this.

RuntimeError: The current Numpy installation ("...venvlibsite-packages umpy\__init__.py") fails to pass a sanity check due to a bug in the windows runtime.

See this issue for more information: https://developercommunity.visualstudio.com/content/problem/1207405/fmod-after-an-update-to-windows-2004-is-causing-a.html

I have tried multiple versions of Python (3.8.6 and 3.9.0) and numpy and pandas. I am currently using PyCharm to do all this.

Answer rating: 192

This error occurs when using python3.9 and numpy1.19.4 So uninstalling numpy1.19.4 and installing 1.19.3 will work.


Edit

As of January 5th 2021 numpy version 1.19.5 is out and appears to solve the problem.

Answer rating: 57

I am using Python 3.7, anyway the same solution suggested here helped me.

pip install numpy==1.19.3

Actually the link informed https://developercommunity.visualstudio.com/content/problem/1207405/fmod-after-an-update-to-windows-2004-is-causing-a.html shows the given solution. It seems to be a bug in Visual Studio, which remains unsolved up to this date.





Get Solution for free from DataCamp guru